[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Cannot easily contribute to the wiki

From: Thomas Schwinge
Subject: Re: Cannot easily contribute to the wiki
Date: Fri, 28 Sep 2018 10:33:54 +0200
User-agent: Notmuch/0.9-125-g4686d11 (http://notmuchmail.org) Emacs/25.2.2 (x86_64-pc-linux-gnu)


On Thu, 27 Sep 2018 18:42:08 -0400, Joshua Branson <jbranso@fastmail.com> wrote:
> "./render_locally".
> $ ymlfront: failed to use YAML::Syck

Nothing else get printed?

> Luckily Parabola packages perl-yaml-syck!  But after I ran installed
> perl-yaml-syck, I still got the same error:
> $ ymlfront: failed to use YAML::Syck
> So I rebooted and tried again.   Same error:
> $ ymlfront: failed to use YAML::Syck
> Granted, on my parabola machine, I'm not sure if I have all of the
> dependancies.  Mainly the wiki says to use apt-get, which I don't have.
> $ apt-get install ikiwiki libyaml-syck-perl markdown libsearch-xapian-perl 
> texinfo
> Here's the dependancies I know I have:
> [joshua@dobby hurd-web]$ pacman -Q markdown texinfo perl-yaml-syck
> discount 2.2.4-1
> texinfo 6.5-1
> perl-yaml-syck 1.30-5

What does the following print?

    $ perl -e 'use YAML::Syck' && echo OK

I do remember commit 178b9e4a14e8ea6fa415c3c36461e41da8434694 "ymlfront:
Force use of YAML::Syck", but that shouldn't cause any problems if the
relevant Perl packages are properly installed.  You might try to
temporarily revert that one, though.

Or, temporarily disable (some of) these plugins, see "ikiwiki.setup".
You should still be able to "render_locally", just some information will
be missing on a few pages.

> So since my Parabola GNU/Linux machine didn't work, I thought I'd try
> the Hurd vm I have.

How do you start the VM?

> Then I booted up my Hurd VM and tried git pulling.
>  fatal: Unable to look up darnassus.sceen.net (port 9418) (Temporary failure 
> in n
>                                        ame resolution)

Same when pulling from savannah.gnu.org, probably?

> I also got this error as the vm was booting:
> ip up: failed to bring up /dev/eth0

Does the information from
help by any chance?

> So, I'm kind of stuck at the moment.  :(

Well, on the contrary, there certainly are enough items here that can be
investigated.  :-)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]