[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: PCI arbiter crash on last qemu image

From: Damien Zammit
Subject: Re: PCI arbiter crash on last qemu image
Date: Sun, 16 Aug 2020 12:46:25 +1000
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.9.0

Hi there,

On 15/8/20 9:49 pm, Joan Lledó wrote
> I downloaded and tried the last qemu image "debian-hurd-20200731.img".
> When I try to read the memory mapped content of region files in the
> arbiter, it crashes and shows the message "Real-time signal 0".

I am also getting this on my latest hurd system that I have been working on.

I ran gdb on pci-arbiter pid, put breakpoints on S_pci_conf_read and 
but seemed to have no effect, and when I continue and then run the hexdump,
I get no useful backtrace, could it be a recursion problem with stack overflow?

Thread 1 received signal ?, Unknown signal.
memcpy () at ../sysdeps/i386/i686/memcpy.S:71
71      ../sysdeps/i386/i686/memcpy.S: No such file or directory.
(gdb) bt
#0  memcpy () at ../sysdeps/i386/i686/memcpy.S:71
#1  0x08059588 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Any ideas?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]