[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

State of SATA development?

From: Paul Dufresne
Subject: State of SATA development?
Date: Wed, 28 Oct 2020 14:14:44 -0400
User-agent: Zoho Mail

On real hardware I have seen a kind of error on loading AHCI: from my memory: phys 0 offline!?

So I tried to emulate a SATA connected cdrom in QEMU with:
qemu-system-i386 -m 700M --device ich9-ahci,id=sata -drive media=cd
rom,if=none,id=sata-cd0,file=debian-sid-hurd-i386-DVD-1.iso -device ide-cd,drive=sata-cd
0,bus=sata.0 --enable-kvm

removing --enable-kvm, I had time to see that AHCI 'driver' seems to load fine, resulting in BAR=something info.

But it seems to get the relatively same error than on real hardware: No device for installation media was detected.

BTW: I found how to do the emulation, from the following web page:

So, I am kind of asking... does someone have SATA working for him/her?
If so... how?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]