[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Debian Hurd tests on real hardware - network, IRQ issues

From: Riccardo Mottola
Subject: Re: Debian Hurd tests on real hardware - network, IRQ issues
Date: Sat, 2 Jan 2021 18:06:30 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0 SeaMonkey/

Hi Samuel,

Samuel Thibault wrote:
>> Since you wrote me you pushed a new kernel, I just did apt-get update,
>> got a new hurd.
>> Unfortunately, the problem persists.
> Ah, indeed, the com driver doesn't actually limits its probing according
> to NCOM. Fixed upstream and pushed as pending for next gnumach upload.

I had some spare time today and tried again - it is a little bit of
fuss, since I need to swap HDs to another computer.

I still get
com0: at atbus0The device below will clobber IRQ4 (c1051200)
You have two devices at the same IRQ.
This won't work. Reconfigure your hardware and try again.
com0: port = 3f8, spl = 6, pic = 4

(the address of IRQ4 above changed slightly)

Now kernel messages look slightly different above and I read before
thgat, something which might be the root issue:

ide: ALI15x3: enabled read of IDE channel state (en/dis-abled) Succeeded
ide: ALI15x3 (dual FIFO) DMA Bus Mastering IDE
   Controller on PCI bus 0 function 128
   ide0: BM-DMA ad 0x8080-0x8087
   ide1: BM-DMA ad 0x8080-0x808f

<details on hd0 hard disk, hd2 CDROM>

ide1 at 0x170-0x177,0x276 on irq 4

so it looks like the problematic IRQ is actually used by ide, later the
serial port shows this issue. Does this enlighten you?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]