[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: bash in X: Failed to fdwalk: Too many open files in the system

From: Paul Dufresne
Subject: Re: bash in X: Failed to fdwalk: Too many open files in the system
Date: Wed, 27 Jan 2021 12:12:16 -0500
User-agent: Zoho Mail

I have xterm (and lxterm) working in Xorg now, but I did not figure out why... yet.

First, trying to do a program with fdwalk, I have come to the conclusion fdwalk does not exist in Debian sid.

My program:

paul@debian:~$ cat fdwalk.c
#include <stdlib.h>
#include <sys/resource.h>
#include <stdio.h>

struct rlimit rl;
int i;
int num_files=0;
int fd;

int countOpenFiles(void *data, int fd){

void main(){
  fdwalk(countOpenFiles, &fd);

result in:

paul@debian:~$ gcc fdwalk.c
fdwalk.c: In function ‘main’:
fdwalk.c:15:3: warning: implicit declaration of function ‘fdwalk’ [-Wimplicit-function-declaration]
   15 |   fdwalk(countOpenFiles, &fd);
      |   ^~~~~~
/usr/bin/ld: /tmp/cc3BVAdS.o: in function `main':
fdwalk.c:(.text+0x4b): undefined reference to `fdwalk'
collect2: error: ld returned 1 exit status

paul@debian:~$ man fdwalk
No manual entry for fdwalk

After that I did: apt-get build-essential; apt-get source bash; apt-get build-dep bash

And I tried to find fdwalk in bahs-5.1 directory with:
paul@debian:~$ cd bash-5.1/
paul@debian:~/bash-5.1$ grep -rnw '/path/to/somewhere/' -e 'fdwalk'
grep: /path/to/somewhere/: No such file or directory
paul@debian:~/bash-5.1$ grep -rnw . -e 'fdwalk'
paul@debian:~/bash-5.1$ grep -rn . -e 'fdwalk'
[I did try with other terms found in files, and that worked]

But I decided to rebuild it with:
then installed generated pkgs with dpkg -i [most .deb except static one] in ..

apt-get install xterm twm

after that I created:
paul@debian:~$ cat .xinitrc
xterm &
exec twm

paul@debian: startx

And then, I was able to position my xterm window on the screen and use it.

I don't know yet if it is the fact to build my own .xinitrc file that did the trick or to rebuild the bash package... will probably reinstall and try just the .xinitrc file
with "apt install xterm twm" to see if it is enough to make it work.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]