[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Can't boot GNU Mach with efi

From: jbranso
Subject: Re: Can't boot GNU Mach with efi
Date: Sun, 07 Feb 2021 01:15:14 +0000

That's cool.  I didn't realize that the Hurd could potentially boot from UEFI.  
That's interesting.

February 6, 2021 6:40 PM, "Paul Dufresne" <dufresnep@zoho.com> wrote:

> ---- Le sam., 06 févr. 2021 16:57:39 -0500 <jbranso@dismail.de> écrit ----
>> So, you got GNU Mach to boot with EFI? Wow! That's awesome!
> No... I had not tried yet when you wrote your message.
> Now, I have tried, and failed.
> I think that a good part of the (my) problem, is that I have made a custom 
> iso, with 
> /media/paul/Debian sid h-i386 1/EFI/boot/BOOTX64.EFI
> (for info, I used isomaster to add it, after having copied it from my own 
> /boot/efi directory
> (using root access) to my $HOME directory, 
> chown $USER ~/BOOTX64.EFI )
> My previous DVD show the DVD in UEFI boot mode in the Boot menu of the 
> firmware, but trying to boot
> it return to the firmware.
> My edited iso would not even show up in UEFI mode in the firmare Boot menu. 
> But "still" works in
> "Normal" CSM mode.
> So I finally realized that CD/DVD are in ISO9660 format... and UEFI partition 
> normally need to be
> in FAT (normally FAT32) to be found by
> the firmware.
> So... it need to be done once the system is installed... I only have access 
> to a working Hurd on
> UEFI system under QEMU... but I probably could try.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]