[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Debian Installer (CD): No device for installation media found

From: Saniya Maheshwari
Subject: Debian Installer (CD): No device for installation media found
Date: Thu, 15 Sep 2022 10:47:39 +0530


As mentioned in the other thread on the help-hurd channel, I am attempting a GNU/Hurd install on an old Dell Inspiron laptop.

Using the image:


I prepared a live CD and managed to boot from it. The Debian installer successfully passes through the language/region/keyboard layout selection steps, and then I get this error "No device for installation media found". (Please note that is a live "CD" and not a USB flash drive; I did read that GNU/Hurd has no support for USB currently.)

This error shows me a prompt asking me to insert any removable media immediately and click "Yes" to try and load modules from it. Since the CD-ROM is already inserted, I do nothing and click "Yes". Here, I get another error saying that no modules were found and that either the removable media is bad or no drivers are found.

Going back again to the original prompt and clicking "No" instead of "Yes", I get another prompt asking me to manually enter the device file. Clicking "Yes" here, I get a window with /dev/cdrom entered by default. It doesn't work with this default entry. Going to the shell, I then try

# ls /dev | grep 'cd'

which gives me two entries: /dev/cd0 and /dev/cd1. Both these entries don't work either.

To check if this is a bug specific to my laptop, I tried out the prepared CD in QEMU/KVM; I get exactly the same errors. Then, to check if this is an issue with my prepared CD, I again tried it out in QEMU/KVM, this time not with the CD, but with the downloaded .iso file. I again get exactly the same errors.

I think this is either a bug in GNU/Hurd's CD-ROM driver, or I am using an incorrect .iso file. Either way, please let me know.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]