[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: libdiskfs assertion failed

From: Joshua Branson
Subject: Re: libdiskfs assertion failed
Date: Wed, 14 Jun 2023 13:38:06 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.1 (gnu)

Samuel Thibault <samuel.thibault@gnu.org> writes:

> Joshua Branson, le ven. 26 mai 2023 11:02:44 -0400, a ecrit:
>> Samuel Thibault <samuel.thibault@gnu.org> writes:
>> > Joshua Branson, le jeu. 25 mai 2023 22:32:24 -0400, a ecrit:
>> >> So I updated my T43 to the bleeding edge Debian in real hardware, which
>> >> come on that is pretty cool!  The update process was pretty easy.  I
>> >> will describe that in the postscript.  I did get this error recently
>> >> when I shutdown the Hurd:
>> >> 
>> >> extfs: ../../libdiskfs/disk-pager.c:107: fault_handler: Assertion
>> >> 'scp->sc_error = 10' failed.
>> >
>> > Mmm, perhaps you can make it print the scp->sc_error value so we get an
>> > idea of what that is?
>> How would I go about printing that scp->sc_error value?
> Add before the assert 
> if (scp->sc_error != EKERN_MEMORY_ERROR)
>     fprintf(stderr, "error %d\n", scp->sc_error);
> and rebuild.
>> I am running this in machine in real hardware.  I get that error message
>> after I run "sudo poweroff".  I see that error message right before the
>> Hurd gets halted.  I imagine I need to turn on the kernel debugger to
>> print that value.
> It'll be hard to catch it from the kernel, which doesn't really care
> much when some program exits.

So I built the hurd via the usual:

apt source hurd
apt install fakeroot build-essential

Then I added this line above line 107 in extfs:

if (scp->sc_error != EKERN_MEMORY_ERROR)
    fprintf(stderr, "error %d\n", scp->sc_error);

Then I build the hurd via 
cd hurd-09.git<NUMBERS>/
dpkg-buildpackage -us -uc -nc -b -rfakeroot
sudo dpkg -i ../*deb

Then I rebooted.  Then I shut down the hurd, and I got the same error

error 2
extfs: ../../libdiskfs/disk-pager.c:112: fault_handler: Assertion
'scp->sc_error = 10' failed.
startup: halting Hurd...

You will notice that the line number changed.  The error message used to
be at line 107 and now it is at line 112.  Is there a log file that I
should check?




Joshua Branson
Sent from the Hurd

reply via email to

[Prev in Thread] Current Thread [Next in Thread]