[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNU indent 2.2.10 bug ?

From: indent
Subject: Re: GNU indent 2.2.10 bug ?
Date: Tue, 06 Oct 2009 19:56:53 +0200
User-agent: Thunderbird (X11/20090817)

address@hidden wrote:
> I'm using GNU indent version 2.2.10 on a Slackware 13.0 64 bit system.
> The texinfo page says any space between a # and "include" is removed by 
> default.
> If you want to leave it the space, then one should use the -lps option.
> Given this one line source file (call it test.c) that has 1 space between
> the # and "include":
> # include <stdio.h>  
> if I run 
>     indent -st test.c
> indent does not make any changes to the file: the space between the # and 
> include
> is left intact.  Just to make sure the default wasn't to leave the space, I
> tried:
>     indent -nlps test.c
> and again indent did nothing: the space between the # and include was 
> maintained.
> in other words, the -nlps option (which is the default) does not work for me.
> I found this while running indent on a much larger file where indent did do
> a lot of clean up for me.   Perhaps I'm misunderstanding what the -nlps
> option is supposed to do, I dunno.  I would appreciate it if someone 
> could kindly look into this and let me know if if you believe it is a
> bug.
Looks like a bug, thanks for reporting it. It seems the regression tests
only test for the opposite action of inserting spaces :-(

reply via email to

[Prev in Thread] Current Thread [Next in Thread]