[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [bug-inetutils] already connected when closed

From: Alfred M. Szmidt
Subject: Re: [bug-inetutils] already connected when closed
Date: Mon, 9 Jul 2007 20:21:48 +0200 (CEST)

       Been trying to reproduce this, but I cannot, admitably I'm
       using CVS

   I checked out inetutils from CVS.  The sigpipe still happens for me
   on my machine after letting the connection silently time out -- not
   100% of the time, but >90%.  I'll append the backtrace, not that
   it's especially illuminating.  The sigpipe happens in the `fflush
   (cout);' call in the `command' function.

Hmph.  Can you put a break point at the fflush, and then examine the
content in gdb?  You can do function calls from gdb, so right before
fflush, you can do:

p fstat (cout, ...)

and such, I think.  This bug is getting far to obscure...

   (BTW 1, I don't see a bootstrap script, just bootstrap.conf, but I
   copied bootstrap from coreutils and that seemed to get things going.

Tss... You didn't read the README-alpha file. :-)

   BTW 2, shouldn't there be Copyright 2007 Free Software Foundation (or
   whatever) added to the copyright notices?)

Yeah, it is a (serious) bug that is on my todo list.  Many files have
incorrect notices and some only the usual MIT-style license.  Sighs.
And now with work, even less time.

   I tried on another host with the same libc and kernel and it worked :(.
   Guess it's something about my terribly (satellite) connection here.  I
   could offer to give you access but I fear it will be unusably slow
   for debugging coming in from outside. 

Can you try it on the host that works, but over a satellite


reply via email to

[Prev in Thread] Current Thread [Next in Thread]