[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [bug-inetutils] _argp_program symbols error

From: Sean B. Palmer
Subject: Re: [bug-inetutils] _argp_program symbols error
Date: Fri, 26 Jun 2009 11:02:23 +0100

On Thu, Jun 25, 2009 at 10:12 PM, Alfred M. Szmidt wrote:

> Could you try:

Each of these three commands:

(1) CFLAGS=-fno-common ./configure && make
(2) CFLAGS=-fno-common LDFLAGS=-fno-common ./configure && make
(3) ./configure; make AM_CFLAGS=-fno-common

Gives the following error message:

gcc -std=gnu99  -fno-common   -o telnetd telnetd.o pty.o term.o
utility.o state.o termstat.o slc.o -L../libinetutils -linetutils
-L../libtelnet -ltelnet -L../lib -lgnu -lcurses     -lresolv
/usr/libexec/gcc/i686-apple-darwin8/4.0.1/ld: multiple definitions of
symbol _not42
utility.o definition of _not42 in section (__DATA,__common)
state.o definition of _not42 in section (__DATA,__data)
collect2: ld returned 1 exit status

Obviously with some variation on the exact failed command, so that in
(2) -fno-common was given twice.

This error is several lines below 'gcc -std=gnu99  -fno-common   -o
hostname hostname.o -L../lib -lgnu -lresolv' for which we were having
the problems before, so I assume that -fno-common solved that bug.

Incidentally, when I ran (1) last night it failed with the old error
message, the missing _argp_program symbols. I assume that this was
because it was in the non-clean build that we'd been tinkering with
prior to running that command. All the build processes above were with
a fresh tree.

Please let me know if you need any further information.

Sean B. Palmer, http://inamidst.com/sbp/

reply via email to

[Prev in Thread] Current Thread [Next in Thread]