[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Incorrect libtool built when cross compiling under Mac OSX

From: Peter O'Gorman
Subject: Re: Incorrect libtool built when cross compiling under Mac OSX
Date: Tue, 16 Dec 2008 00:13:08 -0600

On 15-Dec-08, at 6:28 AM, Rudolf Leitgeb wrote:

Dear Ladies and Gentlemen,

I may have triggered a bug in autoconf and would like to report details here.

I tried to build ImageMagick 6.4.7-4 in an Intel based iMac from sources. As long as I compiled for i386 and x86_64, everything went fine, troubles started, when I tried
to cross compile for ppc and ppc64.

First I created a configure script with autoconf, with this configure script I generated Makefiles and libtool, and this libtool does not work properly.

The following versions were used:

autoconf: 2.63
Mac OSX: 10.5.5
gcc toolchain: from xcode 3.1

Here's a description of my build problems. Note that these problems only appear
when I cross compile for ppc and ppc64!

configure looks for name lister tools, and tries two programs: dumpbin and link I do have /bin/link, which is a hard link to /bin/ln, not a linker, but for some reason configure doesn't discover that "/bin/link -dump - symbols" returns
an error.
For some unknown reason global_symbol_pipe remains empty, which ultimately
causes the make process to fail.

If I remove "link" from the list of programs configure tries to use as BSD name
lister, the build process works.

Please let me know if you need more information.


This report properly belongs on the bug-libtool list, not the bug- autoconf list, CCing both, please remove bug-autoconf when you reply.

I assume that you are doing something like ./configure CC='gcc -arch ppc' CXX='g++ -arch ppc' --host=ppc-apple-darwin9.5.0 ?

Libtool, when looking for a name lister, checks for host = build, and if so, checks for plain old nm as well as ppc-apple-darwin9.5.0- nm, if build != host, it only looks for ppc-apple-darwin9.5.0-nm. I agree that this is a bug. You can workaround by setting NM=/usr/bin/nm for configure.

I'll come up with a patch tomorrow, too tired right now.

Peter O'Gorman

reply via email to

[Prev in Thread] Current Thread [Next in Thread]