[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problem with startup script under SuSE 7.2

From: Anders Gorm Pedersen
Subject: Problem with startup script under SuSE 7.2
Date: Tue, 23 Oct 2001 13:47:14 +0200 (CEST)

Dear address@hidden,

I recently upgraded my Suse-distribution to version 7.2 (with KDE)
including all packages. This apparently includes your very interesting
piece of software.

BUT, I think there may be a problem with one of the scripts that is
included in the package. (I'm no system administrator, so possibly Its
my mistake....). Specifically, the script


contains two lines that caused startup problems:

setenv GS_FONTPATH "$datadir/afm:/usr/share/lilypond/pfa:$GS_FONTPATH"
setenv GS_LIB "$datadir/ps:$GS_LIB"

Apparently the "recursive" definition of the environment variables
(GS_FONTPATH is part of the definition of itself) does not work.
Specifically, this had the weird effect that anytime I tried to rlogin or
telnet to my machine, my startupscripts (.cshrc and such) were not called,
and I got the error message "GS_FONTPATH: undefined variable". (That was
rather hard to debug by the way...). It seems that tcsh stops after
reaching this line, causing the rest of the startup to be skipped.
Removing the trailing :$GS_FONTPATH and :$GS_LIB solved the problem.

Hope this is relevant!

Best regards,
Anders Gorm Pedersen

 Anders Gorm Pedersen, cand.scient., Ph.D.  (address@hidden)

 Center for Biological Sequence Analysis
 Technical University of Denmark
 Bldg 208, DK-2800 Lyngby, Denmark

 phone: (+45) 45 25 24 84
 fax:   (+45) 45 93 15 85

 Web: http://www.cbs.dtu.dk/gorm/

reply via email to

[Prev in Thread] Current Thread [Next in Thread]