[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Missing notes in 1.4.12

From: Mats Bengtsson
Subject: Re: Missing notes in 1.4.12
Date: Tue, 23 Apr 2002 11:42:34 +0200

Have you tried to run with 'ly2dvi -V ...'? It usually helps.

I ran into a similar problem in some of the more recent 1.5.x versions.
I sent the example file privately (for copyright reasons) to Han-Wen
and Jan who couldn't repeat my problem. What helped for me was to
upgrade my Guile installation from 1.4 to the latest beta version
1.5.6 which is available from ftp://alpha.gnu.org/gnu/guile/

It's really a pity if we cannot rely on the officially available
Guile releases, but as you say, this is extremely tricky to debug.


> After the insane amounts of 1.5.53 bugreports i decided to finish up my 
> piece in 1.4.12. But - ARGH - an old bug which afair HAS BEEN fixed and 
> downgraded to 1.4 reappeared.
> Sorry for attaching enormous example - I tried to add a comment to the 
> problem-line but even THE COMMENT removed the problem. Really haven't 
> got time to minimize this example without destroying the bug.
> Well, the bug is that the quarter rest on line 168 of BugNotes.ly is 
> ignored (top staff, measure 19) when processing BugScore.ly. In 1.5.53 
> there are no problems  (well, not this problem, that is) - but bugs that 
> come and go randomly ARE tricky so I decided to report this nevertheless.
> Please reply that the bug is known and has been fixed and that the fix 
> HAS NOT been downgraded to 1.4... Otherwise the bug is probably still 
> there - somewhere waiting to pop up in a real inappropriate time. :-(
> -Rune (getting desperate - trying to finish this #¤%&#%¤ piece)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]