[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 1.5.54 make install failed

From: Guéry Olivier
Subject: Re: 1.5.54 make install failed
Date: Thu, 25 Apr 2002 01:53:50 +0200

Le 2002.04.24 20:13, Mats Bengtsson a écrit :
Hmm, my patches to try to fix problems haven't been too successful
What I did was to use the 1.5.2 implementation of the 're' package
even for newer versions of Python. This solved the problems that
were reported some week ago if you used Python 1.6-2.1.
Apparently, it caused some other problems instead, if you have
Python version 2.2.

Could you please try the attached patch. Unfortunately, I'm
unable to try it out here. I tried to install Python 2.2
quickly on my machine but keep getting an error message about
a missing module 'operator'. I'm not sure how this Python
installation was built (I just copied it from another machine
where I don't have access to Lilypond) so it may be a problem
of my installation.

Also, could someone please verify that it still solves the
bug reported in
if you have Python 2.2. I'm afraid it won't.


Here is the result after the patch (sorry, but I can't do much more than testing it...) :

make[1]: Entre dans le répertoire `/sources/lilypond/lilypond-1.5.54/Documentation' make PACKAGE=LILYPOND package=lilypond -C user all && make PACKAGE=LILYPOND package=lilypond -C bibliography all && make PACKAGE=LILYPOND package=lilypond -C pictures all && make PACKAGE=LILYPOND package=lilypond -C topdocs all && make PACKAGE=LILYPOND package=lilypond -C misc all && make PACKAGE=LILYPOND package=lilypond -C windows all && true make[2]: Entre dans le répertoire `/sources/lilypond/lilypond-1.5.54/Documentation/user'
rm -f out/lilypond.nexi
/usr/bin/python ../.././scripts/lilypond-book.py -I /sources/lilypond/lilypond-1.5.54/Documentation/user -I ./out -I../.././input -I ../.././input/tricks/ -I ../.././input/regression/ -I ../.././input/test/ -I ../.././input/tutorial/ -I /sources/lilypond/lilypond-1.5.54/mf/out -I /sources/lilypond/lilypond-1.5.54/mf/./out/ --dependencies --outdir=./out --format=texi --no-lily lilypond.tely
invalid regexp: a
Traceback (most recent call last):
  File "../.././scripts/lilypond-book.py", line 546, in ?
    raise "Invalid re"
Invalid re
make[2]: *** [out/lilypond.nexi] Erreur 1
make[2]: Quitte le répertoire `/sources/lilypond/lilypond-1.5.54/Documentation/user'
make[1]: *** [all] Erreur 2
make[1]: Quitte le répertoire `/sources/lilypond/lilypond-1.5.54/Documentation'
make: *** [all] Erreur 2
1:47 nemo:~/sources/lilypond/lilypond-1.5.54 %

If you want me to tried something else, don't esitate


Olivier Guéry <address@hidden>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]