[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Bizzare segfault

From: Nathan Hurst
Subject: Bizzare segfault
Date: Wed, 23 Jul 2003 21:58:04 +1000

I was slightly changing a piece of music and it became too long to fit on one 
page, so I tried changing the paper size from paper20 to paper16.  ly2dvi then 
crashed with this error:

Running LilyPond...
GNU LilyPond 1.6.9
Now processing: `introit-2-piano.ly'
Interpreting music...[8][16]
Preprocessing elements...
Calculating column positions... [3][6][9][12][15][16]
paper output to `introit-2-piano.tex'...
writing header field `title' to `introit-2-piano.title'...
writing header field `composer' to `introit-2-piano.composer'...
Interpreting music...error:
LilyPond crashed (signal 11).Please submit a bug report to address@hidden
Traceback (most recent call last):
  File "/usr/bin/ly2dvi", line 1047, in ?
    run_lilypond (files, dep_prefix)
  File "/usr/bin/ly2dvi", line 549, in run_lilypond
    error ("\n\n" + _ ("LilyPond crashed (signal %d).") % signal \
  File "/usr/bin/ly2dvi", line 152, in error
    sys.exit (2)
SystemExit: 2

The strange thing is that when I reverted to the original file that worked, 
lilypond still crashes.  Other lilypond files still work fine.
So I presume there is some state being kept around (or maybe I've 'broken' the 
file somehow).


reply via email to

[Prev in Thread] Current Thread [Next in Thread]