bug-lilypond
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Fwd: source lilypond.profile failed 1.7.30 address@hidden


From: Olivier Guéryry
Subject: Re: Fwd: source lilypond.profile failed 1.7.30 address@hidden
Date: Mon, 4 Aug 2003 16:59:36 +0200

Hello,
sorry for my bad english, you won't understand. When i run the command my terminal died ! It's not me killing him, it's a sucied :o) My shell is zsh 4.1.0-dev-7 (i686-pc-linux-gnu) (from gentoo stable ebuilt).
I tried the changes Han-Wen sugest. One question : must I have to put
'echo invoked as "$0"' in replacment of 'exit 2' ?
When I do this, here is the output (the terminal have not died).
localhost/nemo-/home/sources/lilypond/lilypond-1.7.30/buildscripts/out $ source ./lilypond-profile Error: This script cannot be run in a subshell; it MUST be sourced.
  EXAMPLE 1: One time use
         Do
             . ./lilypond-profile
   EXAMPLE 2: Local installation
         * Do
             mv lilypond-profile /home/nemo/bin/
         * Add
             .  /home/nemo/bin/lilypond-profile
         to either /home/nemo/.profile or /home/nemo/.bash_profile,
         * Logout.
  EXAMPLE 3: Global installation
         * Do
              mv lilypond-profile /etc/profile.d/lilypond.sh
         * Logout
   invoked as ./lilypond-profile


That's all, but the TEXMF is on, and I can use lilypond.

Némo. --
Olivier <address@hidden>


On 2003.08.04 12:40, Mats Bengtsson wrote:
What was it that didn't work?

You have to source the script in the shell window where you later
want to use LilyPond, so I don't understand why you killed your
terminal. Exactly what command did you use to source the file?
What shell do you use?

   /Mats


Olivier 翽 wrote:
On 2003.08.03 12:00, Olivier Guéry�ry wrote:
Hello,
After compilation, and installation, doing a 'source buildscripts/
out/
lilypond-profile' kill my terminal (gnome-term).
I only tried the first of the 3 exemple
I tried with lily 1.7.27 with no problem but it apear in 1.7.29.
Reading the changelog it seems that changes apear in this file with the 1.7.28
Here is my configuration : gentoo 1.4 / gnome 2.3.3

Némo.


--
=============================================
        Mats Bengtsson
        Signal Processing
        Signals, Sensors and Systems
        Royal Institute of Technology
        SE-100 44  STOCKHOLM
        Sweden
Phone: (+46) 8 790 8463 Fax: (+46) 8 790 7260
        Email: address@hidden
        WWW: http://www.s3.kth.se/~mabe
=============================================





reply via email to

[Prev in Thread] Current Thread [Next in Thread]