[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Error compiling 1.6.20 and 1.8.1

From: Michael Edwards
Subject: Error compiling 1.6.20 and 1.8.1
Date: Sun, 24 Aug 2003 18:55:58 -0400

I get the same error when I try to compile either 1.6.12 or 1.8.1:

mv out/lilypond.texi out/lilypond.nexi
chmod -w out/lilypond.nexi
makeinfo --output=./out/lilypond.info out/lilypond.nexi
cd ./out && /home/edwards/tarballs/lilypond-1.6.12/lily/out/lilypond
make[2]: *** [out/lilypond-internals.nexi] Error 139
rm out/lilypond.nexi
make[2]: Leaving directory
make[1]: *** [all] Error 2
rm out/index.texi
make[1]: Leaving directory
make: *** [all] Error 2

It seemed to be a problem with the compiled binary.  Sure enough, when I
ran it, I got a seg fault.  Here's the backtrace I ran with gdb on
lilypond 1.6.12:

#0  0x0805208e in String_handle::~String_handle() (this=0xbffff6c0)
    at include/string-handle.icc:22
#1  0x080ecaaa in setup_paths() () at
#2  0x080eff4c in main (argc=1, argv=0xbffff884) at main.cc:415
#3  0x42017589 in __libc_start_main () from /lib/i686/libc.so.6

That's similar to what happened with 1.8.1--something with
string-handle.icc at line 22.

Any ideas?  I'm running Redhat 7.3, but I have upgraded a number of
different things, including guile (1.6.4).  I compiled 1.8.1 with gcc
3.0 and 1.6.12 with gcc 2.96.  


reply via email to

[Prev in Thread] Current Thread [Next in Thread]