[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Suspected bug in lilypond 2.4.0

From: Charlie Wilkins
Subject: Suspected bug in lilypond 2.4.0
Date: Sun, 31 Oct 2004 22:12:20 -0600
User-agent: Mozilla Thunderbird 0.8 (X11/20040913)

Dear Jan and Han-Wen,
I just downloaded and installed lilypond 2.4.0 and I am quite impressed, however, I think I may have already found a bug, or at least an inconsistency, in the program. I was a little concerned because your site said 2.4.0 was packaged for Fedora Core 3 (I am using Fedora Core 2 on an Athlon, here) but the package installed with no problems.

I ran midi2ly to produce a .ly source file from the attached MIDI file. It is "Suscepit Israel" from the Pergolesi "Magnificat in B-dur". I have also attached the output from midi2ly (4-suscepit-midi.ly) for you to test or compare. When I tried to compile 4-suscepit-midi.ly, I got the following output:

   address@hidden ninewands]$ lilypond 4-suscepit-midi.ly

   Now processing `4-suscepit-midi.ly'

   error: syntax error, unexpected $end

   4-suscepit-midi.ly:39:13: warning: Braces don't match:
                A = \relative c {

   error: failed files: 4-suscepit-midi.ly

I loaded up the .ly file in emacs with Paren Highlighting on in "Show Paren mode" and there were no unmatched braces. I found the same results when I tried this under lilypond 2.2.6, so it may be some problem with the MIDI file, but I would have expected midi2ly to fail in that case.

By the way, the lilypond mode for emacs is great. Can you give me any tips on how to get it to work with Xemacs under Fedora? Thanks for you excellent work. Lilypond is software that does exactly what it claims to do and I find that very impressive.

Charles Wilkins

Attachment: 4-suscepit.mid
Description: MIDI audio

Attachment: 4-suscepit-midi.ly
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]