[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Difficulties with testing installation on a Mac

From: Paul Scott
Subject: Re: Difficulties with testing installation on a Mac
Date: Sun, 21 Nov 2004 20:54:58 -0700
User-agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.7.3) Gecko/20041007 Debian/1.7.3-5

Paul Morris wrote:
I actually got it installed and tested on my mac, but with two stumbling blocks along the way... (related to the documentation / instructions)

(If this is not the correct email address for this, please forward to the appropriate one, Thanks!)

1. It wasn't clear where to save the "test.ly" file. (when following directions at: http://lilypond.org/web/download/getting-started.html) After a few tries I found that it is the user directory, ie: /hard-drive/users/username/

2. The following text in the test.ly file:

    c4( c)

lead to the following error:

    lilypond (GNU LilyPond) 2.2.5
    Running lilypond-bin...
    Now processing `test.ly'

    /Users/paul/test.ly:1:1: error: parse error:

    /Users/paul/test.ly:2:3: warning: Braces don't match:
    Failed files: test.ly

    lilypond: error: LilyPond failed on input file test (exit status 1)
    lilypond: warning: Running LilyPond failed. Rerun with --verbose for
    a trace.

So I eventually found and tried this text:

    % This file has ledger lines and a slur

    \score { \notes { c4-( c4-) } }

from this page for Windows users: http://lilypond.org/web/download/windows.html

and that worked...

\notes became unnecessary somewhere between 2.2 and 2.4. Your test seems to indicate that it was between 2.2 and 2.2.5. Were you using 2.2.5 documentation or something later?

Paul Scott

reply via email to

[Prev in Thread] Current Thread [Next in Thread]