[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: Issue 1670 in lilypond: Allow numbers in variable names: violin1mvt2
Re: Issue 1670 in lilypond: Allow numbers in variable names: violin1mvt2 = c'
Fri, 28 Oct 2011 06:42:22 +0000
Comment #10 on issue 1670 by address@hidden: Allow numbers in variable names:
violin1mvt2 = c'
Fine modest proposal. But customHtuning is harder to read/type. I'd have
chosen a different name, but to be fair: this variable is only used in the
context of specifying a _Scheme_ expression not otherwise useful to
Lilypond, namely as #custom-tuning. There _is_ a notable difference
between #xxx and \xxx right now: if xxx is a music function, #xxx names it,
but \xxx _calls_ it. And one needs the difference even when I continue on
my quest of autoexporting Scheme expressions in every conceivable context:
need to stay different in meaning.
As another example of identifiers not generally useful as Scheme variables,
take a look at scm/define-music-properties.scm. I don't particularly like
the various different identifier syntaxes, though.