[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Special characters in path using lilypond-book with Texshop engine

From: Dona Mommsen
Subject: Re: Special characters in path using lilypond-book with Texshop engine
Date: Fri, 4 May 2012 11:15:04 +0200

Hi Colin and Nicola,

today, I had a little bit time do so some tests. I have no solution, since I 
understand nothing of the internal workings of Lilypond or TeXShop, but maybe I 
can give you some leads. To me, it looks as if the issue is on the side of the 
TeXShop engine.

I can run the test file from Nicola's Website with lilypond-book from the 
command line, even if there are special characters in the path:
~/Documents/Data Personal/Flûte-à-bec/Test-Lilypond-book > lilypond-book -o out 
--pdf test-lilypond-book.lytex

in resulting file in the subdirectory out/test-lilypond-book.tex
I had to remove the line invoking the lilypond-book engine:
% !TEX TS-program = LilyPond-Book

Then typesetting with the TeXShop  (standard Latex engine) worked without any 

(see attached correct output file)

Attachment: correct-test-lilypond-book.pdf
Description: Adobe PDF document

Then I tried the same file with the lilypond-book TeXShop engine. 

That's what I get when I invoke the lilypond-book engine in TeXShop:
– two subdirectories test-lilypond-book-lily and test-lilypond-book-out
–  test-lilypond-book-lily contains subdirectories for the snippets and two 
files for the snippet map and the snippet list

However, the file
has no file extension (.pdf) for each snippet that it wants to include.

Next, I added manually the .pdf file extension for each snippet. For example in:

% eof

With .pdf extension:
% eof

With this, TexShop is at least able to produce a file, but its a bit messed up, 
as it prints the pathnames for each file (see attached 
scrambled-lilypond-book.pdf). I'm sure that I missed many places to add things, 
yet I hope that this might help Nicola to understand what's going on.

Please note also how the section of the pathname with special character looks 
in each systems.tex: FluÃÇte-aÃÄ-bec/

Nevertheless, the .tex file seems to be able to find the files.

Nicola, I hope these findings will help you debugging the TexShop engine.
Thanks in advance for your help!



Attachment: scrambled-lilypond-book.pdf
Description: Adobe PDF document

On May 3, 2012, at 6:19 PM, Colin Hall wrote:

> On Wed, May 02, 2012 at 09:59:46PM +0200, Nicola Vitacolonna wrote:
>> On 2 May 2012, at 11:33 , Dona Mommsen wrote:
>>> Hi,
>>> I'm using
>>> ??? Lilypond-book (v.2.14.2) with TeXShop (v2.43) on Mac OS X (v10.7.3). 
>>> with Nicola Vitacolonna's engine for TexShop
>>> http://users.dimi.uniud.it/~nicola.vitacolonna/home/content/lilypond-engines-texshop
>>>> The engine(s) cannot handle special characters in the path names, even 
>>>> when they do not appear in a relative path
>>> [???]
>>> However, I don't now if this is an issue due to lilypond-book or due to the 
>>> TexShop engine.
>> My TeXShop engine is a very simple tcsh script that sets some environment 
>> variables then calls the lilypond executable. To confirm that the problem is 
>> lilypond you may run it directly from the Terminal, passing a full or 
>> relative path.
>> From the results of your tests, however, I think that it is possible to 
>> modify my engine so that it works with arbitrary paths. I???ll try to look 
>> into it during the weekend.
> Thanks for picking that up, Nicola.
> If you find that the problem lies with Lilypond please let us know and the 
> bug-squad deal with it.
> Until then, we'll treat this report as evidence of a limitation of your 
> TexShop engine, rather than a bug in either your engine or Lilypond.
> Cheers,
> Colin.
> -- 
> Colin Hall

reply via email to

[Prev in Thread] Current Thread [Next in Thread]