[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problems with 'scripts/auxiliar/doc-section.sh

From: Urs Liska
Subject: Problems with 'scripts/auxiliar/doc-section.sh
Date: Mon, 15 Apr 2013 15:34:26 +0200
User-agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20130329 Thunderbird/17.0.5


I'm having problems with the script to build only one doc section.
I have LilyPond from the Git repository, on branch master, latest fetches.

When running the script I get the following error:

 did not exist; is administration a valid section in the contributor manual?

Looking into the script I see that on line 85 SECTION_PATH is suffixed with ".itely". But I see that some files from the documentation are .itely files and some .itexi.

Shouldn't the script find .itely files as well as .itexi files automatically?

The attached patch seems to fix the problem (as far as I can see with my limited experience):

First SECTION_PATH is constructed without extension.
If a file with one of the two extensions is present then that extension is added to SECTION_PATH
If none is present the check will fail (and spit out an updated error message).

I tried this with both an .itexi and an .itely file, and both worked.

I hope this works and can be included into the main source.

Another issue with that script in a separate mail.


Attachment: 0001-doc-section.sh-Fix-.itexi-.itely-issue.patch
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]