[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: bison-3.0 fix lilypond

From: gabriele balducci
Subject: Re: bison-3.0 fix lilypond
Date: Wed, 28 Aug 2013 00:47:37 -0700 (PDT)


  >> I've tried that but see a new error while generating documentation:
error: syntax error, unexpected REAL
  >>   <
  >>    c e gis>1-\markup { "+" }
  > Nothing there with the slightest similarity to a REAL.  Perhaps remnants
  > from a compilation eith different tools: try make clean.


  > Also, I've heard from another person who saw this same issue and had
  > found my email in a search engine.

It's probably me.

After emailing to thomas, I have done some more investigation and all
seems to point (again) to bison-3.0

Building 2.17.25.

If I use bison-2.7.1 (everything else unchanged) I can build just fine.

Switching to bison-3.0 produces the above error (same result with

Unfortunately, I am not in the position to go deeper than this, as I
have 0 knowledge about bison. I have only seen that the error is
printed by parser.cc, whose first line says:

    /* A Bison parser, made by GNU Bison 2.7.12-4996.  */

I guess that parser.cc is generated from parser.yy, so some bison-3.0
issue makes sense...

I will be happy to send any other information or to make any other
test which might be useful in this regard

thanks a lot for developing and making publicly available lilypond


View this message in context: 
Sent from the Bugs mailing list archive at Nabble.com.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]