[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Unable to generate output

From: pkx166h
Subject: Re: Unable to generate output
Date: Sun, 15 Dec 2019 16:50:55 +0000
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.2.2

Hello David,

I didn't notice any reply to you on this:

On 03/12/2019 09:51, David Honour wrote:

Since I did a system update I've been unable to get a PDF out of lilypond, the 
smallest example I've found to trigger is:

It would appear the ghostscript is unhappy with the postscript in the tempfile, 
error is:
Error: /rangecheck in /--.parsecff--
Operand stack:
    false   --nostringval--
Execution stack:
    %interp_exit   .runexec2   --nostringval--   --nostringval--   
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--   
--nostringval--   false   1   %stopped_push   1990   1   3   %oparray_pop   
1989   1   3   %oparray_pop   1977   1   3   %oparray_pop   1833   1   3   
%oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   
--nostringval--   --nostringval--   2   %stopped_push   --nostringval--   
--nostringval--   --nostringval--
Dictionary stack:
    --dict:735/1123(ro)(G)--   --dict:0/20(G)--   --dict:76/200(L)--   
--dict:14/20(ro)(G)--   --dict:7/30(L)--
Current allocation mode is local
Current file position is 65691
GPL Ghostscript 9.50: Unrecoverable error, exit code 1

The tempfile that error resulted from processing is here:

The versions of some packages I thought might be involved (in case that's 
lilypond 2.19.83 (also tried 2.19.80)
ghostscript 9.50 (also tried 9.26)
guile 2.24
fontconfig 2.13.0-r4
freetype 2.9.1-r3
pango 1.42.4-r2
gcc 9.2.0

Let me know if there's any more information needed, or anything I can help with.

At this time we're only officially supporting Guile 1.8 - there is / has been work to get Guile 2.x working but at this time it isn't officially supported.

If you've used ghostscript 9.26 (which is what I am running) then I'd suggest that Guile is the suspect here. Do you know if this was one of the packages updated with whatever Linux update you did?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]