[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Crash on macOS in vasnprintf due to too old gnulib

From: Marvin Scholz
Subject: Crash on macOS in vasnprintf due to too old gnulib
Date: Sun, 26 Jul 2020 20:57:43 +0200


I've encountered a crash in m4 that happens due to too old gnulib, as
its implementation of vasnprintf uses %n in a non-constant format string
which is not allowed on macOS since macOS 10.13 and leads to a crash.

This was fixed in gnulib upstream in c41f233c4c38e84023a16339782ee306f03e7f59
and 7df04f9b8a0adb1575ca0555775ec10860143cbf but the gnulib in m4 does not
seem to be yet updated to that version.

I tried to do that so I could submit a patch, but could not figure out how,
as just updating the submodule and running gnulib-tool to update was not
enough apparently. (It worked but running bootstrap again would still
give me the old version again)

It would be great if someone more familiar with this could update gnulib
to a version that includes the mentioned commits or let me know whats the
correct procedure for updating gnulib then I would submit a patch with the
needed changes.

Thanks in advance,
Marvin Scholz

reply via email to

[Prev in Thread] Current Thread [Next in Thread]