[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Bugs in build.sh script

From: Wirawan Purwanto
Subject: Bugs in build.sh script
Date: Thu, 11 Sep 2003 18:25:19 -0400 (EDT)


I found some bugs in the most recent make's build script: this pertains 
GNU Make version 3.80 (straight from the original release tarball). 

I tried to build it under IRIX 6.5 (uname -a gives:

 1% uname -a
IRIX64 turtle 6.5 07091542 IP27


Since there was NO gnu make available in the platform when I built this 
program, I tried to follow the suggestion in README, i.e. to build using 
"build.sh" script.

Here are some troubles:

* build.sh.in:33: The definition @REMOTE@ is no longer properly 
maintained. Why is this?

* build.sh.in:32: The definition of @LIBOBJS@ here was replaced by 
loadavg$U.o  (including the literal '$U' substring there!) I guess 
this is what happens:
  - IRIX does not have the getloadavg() function, so 
  - autoconf would include the make's version of it, and
  - LIBOBJS is set to 'getloadavg$U.o' (with the literal '$U' there,
    I saw it in the config.status file!)
  - this substitution was transferred to build.sh, and ... voila,
    the bug appears.

Suggested repairs

on line 33: just replace '@REMOTE@' with 'stub' : I found no other
occurence of '@REMOTE@' in the source tree. Could this just be a remain
from older versions?

on line 32: let it be, but we must insert the following statement before 
line 54 of build.sh.in:

extras=`echo "$extras" | sed -e 's|\$U||g'`

in order to remove the '$U' junk from the extras.

Please the UNIX geek make sure that this statement is not "too 
sophisticated" for those old shells out there. I'm a bash user, so I tend 
to be spoiled by nice bash syntax. :-)

Let me know if these workarounds are not good enough. ;-)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]