[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

problems with Net-PCap

From: sofia
Subject: problems with Net-PCap
Date: Tue, 05 Dec 2006 00:35:14 +0100


I'm trying to install the packages Net-Pcap0.14 but it's impossible to
do "make",it reports:

/usr/bin/ld: /usr/local/lib/libpcap.a(pcap-linux.o): no se puede usar la
reubicación R_X86_64_32 contra `a local symbol' cuando se hace un objeto
compartido; recompile con -fPIC
/usr/local/lib/libpcap.a: no se puede leer símbolos: Valor erróneo
collect2: ld returned 1 exit status
make: *** [blib/arch/auto/Net/Pcap/Pcap.so] Error 1

I have tried with -fPIC and with several options(-k,-i,-B..) but it
always happens the same.

I have an AMD64 and Ubuntu 6.10,
I have also installed tcpdump ,version 3.9.4-4 ,and this libraries:
   dpkg -l "*libpcap*"
| Estado=No/Instalado/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err:
||/ Nombre                    Versión                  Descripción
pn  libpcap-dev               <ninguna>                 (no hay ninguna
descripción disponible)
ii  libpcap0.7                0.7.2-7                   System interface
for user-level packet capture
pn  libpcap0.7-dev            <ninguna>                 (no hay ninguna
descripción disponible)
ii  libpcap0.8                0.9.4-2                   System interface
for user-level packet capture
ii  libpcap0.8-dev            0.9.4-2                   Development
library and header files for libpcap 0.8
besides almost all the packages that start with libnet- and end with

I don't know what the error is,and a  friend of mine have the same error
with the same architecture

Could you please answer me??

Thank you very much,

Sofía Muñoz Vélez

reply via email to

[Prev in Thread] Current Thread [Next in Thread]