[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: BUG while running the make file

From: Martin Dorey
Subject: RE: BUG while running the make file
Date: Wed, 7 Feb 2007 10:22:48 -0800

Yes, that is a bug *while running* make.  Perhaps we should rename the mailing 
list to address@hidden or otherwise try to indicate in the error message that 
this isn't likely to be a bug in make.  Perhaps we're doomed though.  For one 
thing, this bug looks unlikely to be a bug in lprng, which is where we'd have 
tried to send the user if we'd have tried to automatically suggest where the 
bug is.

I'd have to suspect a gcc misconfiguration, which might be diagnosed with the 
help of the suggestion here:


Or an assembler bug which might have been already reported here:


My five minutes of googling didn't turn up a more certain or complete answer, 
I'm afraid.  All I can tell you for sure is that it isn't a bug in make.  I 
downloaded the Debian source for lprng and I couldn't see any obvious 
assembler, specifically not in linksupport.c, so I don't think you've got an 
lprng-specific problem, unless lprng is somehow using the wrong gcc or 
assembler.  I didn't find anything in google suggesting that anyone's seen this 
before with lprng, which suggests it's more likely something peculiar to your 
system or a bug in a different package (like gcc or gas).

Sorry, but I don't think we can help you any further on this list.  Good luck.
Martin's Outlook, BlueArc Engineering
From: address@hidden [mailto:address@hidden On Behalf Of Raheja, Himanshu
Sent: Wednesday, February 07, 2007 8:52
To: address@hidden
Subject: BUG while running the make file

I am trying to Install LPRng on my Red Hat Linux Box (x86_64).
After executing ./configure 
I am typing "make" and getting following errors :
/bin/sh ../libtool --mode=compile gcc -I.. -I. -I./include -I./common 
-D_FILE_OFFSET_BITS=64 -I/usr/include  -g -W -Wall  -Werror  -Wno-unused  -g 
-O2 -D_FILE_OFFSET_BITS=64 -g -W -Wall  -Werror  -Wno-unused  -DHAVE_CONFIG_H 
-c ./common/linksupport.c
gcc -I.. -I. -I./include -I./common -D_FILE_OFFSET_BITS=64 -I/usr/include -g -W 
-Wall -Werror -Wno-unused -g -O2 -D_FILE_OFFSET_BITS=64 -g -W -Wall -Werror 
-Wno-unused -DHAVE_CONFIG_H -c ./common/linksupport.c -o linksupport.o
/tmp/ccsjrIuh.s: Assembler messages:
/tmp/ccsjrIuh.s:1368: Error: Incorrect register `%rax' used with `l' suffix
/tmp/ccsjrIuh.s:1617: Error: Incorrect register `%rax' used with `l' suffix
make[1]: *** [linksupport.lo] Error 1
make[1]: Leaving directory `/home/gams/lprng/LPRng-3.8.28/src'
make: *** [src] Error 2
Kindly look into this matter and let me know what needs to be done.
I will be really grateful.
Thanks and Regards

reply via email to

[Prev in Thread] Current Thread [Next in Thread]