[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: not linking

From: Sebastian Pipping
Subject: Re: not linking
Date: Sat, 22 Dec 2012 17:24:10 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/17.0 Thunderbird/17.0

Hello Jack,

On 22.12.2012 15:20, Jack Riegel wrote:
> I created  a 2-line fortran program and a simple make file (below) to
> illustrate the problem that I am having.  When I run make, I get the
> following output.   Note that if I simply copy and paste the final
> gfortran line (the linking step) into my terminal window, the
> executable builds.  It is as if  make is overriding the normal
> library location.  I have not tried specifying a library location,
> but it does not seem that it should be necessary.

seems to work well over here.  Are you using a version of GCC that does
not come with your GNU/Linux distribution?

# make
gfortran -c makeTest.f90
gfortran makeTest.o -o makeTest.x

# ./makeTest.x

# which gfortran

# gcc -dumpversion

# make -v | head -n 1
GNU Make 3.82

# uname -m



reply via email to

[Prev in Thread] Current Thread [Next in Thread]