[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Checking software build tries for “commands.cmo”

From: SF Markus Elfring
Subject: Checking software build tries for “commands.cmo”
Date: Tue, 13 Jun 2017 19:28:02 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.1.1


I am testing the following pattern rules with the program “GNU Make 4.2.1-1.7”
on my openSUSE Tumbleweed system as I would like to adjust some areas
in affected make scripts for another evolving software tool.

%.cmi: %.mli
        $(OCAMLC_CMD) -c $<

%.cmo: %.ml %.cmi
        $(OCAMLC_CMD) -c $<

%.cmx: %.ml %.cmi
        $(OCAMLOPT_CMD) -c $<

I have tried a specific command out.

address@hidden:~/Projekte/Coccinelle/20160205/commons> LANG=C make -d 
common.cmo V=1
Must remake target 'common.cmo'.
/usr/bin/ocamlc.opt …
Removing child 0x557e31ae64e0 PID 2693 from chain.
Successfully remade target file 'common.cmo'.

This test showed the expected results.

I have tried another command variant out.

address@hidden:~/Projekte/Coccinelle/20160205/commons> LANG=C make -d 
commands.cmo V=1
 No implicit rule found for 'commands.cmo'.
 Finished prerequisites of target file 'commands.cmo'.
Must remake target 'commands.cmo'.
Successfully remade target file 'commands.cmo'.
make: Nothing to be done for 'commands.cmo'.

Now I wonder why I do not get the desired software generation results for
this test case. Why is the source file “commands.ml” not compiled again
in the way as the other one?

I am curious for your advices to improve the involved system dependencies.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]