[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-mit-scheme] mysteriously vanishing filed messages

From: Julie Sussman
Subject: [Bug-mit-scheme] mysteriously vanishing filed messages
Date: Sun, 12 Jul 2009 14:24:22 -0400
User-agent: IMAIL/1.21; Edwin/3.116; MIT-Scheme/7.7.90.+

I used o to file some messages from my inbox to an existing rmail
file.  Before expunging them from the (imap) inbox, I looked (with
imail) at the target file to see if the messages were there, and they
weren't.  The summary buffer for the file still showed 44 messages.  I
don't know why I did this, since writing them failed, but I wrote them
all out again (I don't remember whether I did anything inbetween), and
this time they appeared -- the summary now showed 50 messages.
So, feeling secure, I expunged them from the inbox.

But now the messages are not there (not in the file
I wrote them out to)!  I tried regenerating the summary
buffer for that file, but still found only the original 44 messages.
I killed the edwin buffers for that file and tried imail input
on the file again, but it still didn't have the "new" messages.
The target file clearly did not get updated, as it
is dated 2009-07-08 and today is the 12th.  And of course
if I look inside it as raw text, the messages I thought I
wrote today are not there.

I think that at some point I did a q to quit from looking
at the file in question.  I probably didn't do an s to save
the changes to disk.  But the documentation says that q
on a file folder saves changes to the file, so s shouldn't
be necessary.

As usual, of course I cannot reconstruct (in my mind) the
exact sequence of what I did.  (Why would I memorize it
unless I expected to lose?!)

Fortunately I had copied the text I wanted from these
messages to another place, so although I no longer have
these messages, I have the key info from them.
However, this does not inspire confidence!

By the way, these were messages that people resent me at my request,
because I thought I had filed them (to rmail files) but later found
they were not there.  I'm not completely sure whether I supposedly
filed them in the same file I'm having trouble with now, but that was
one of the two possible places I might have put them.

Is there any point in giving you the file that stuff doesn't seem
to save to?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]