[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ncurses, libtool, and os x

From: Thomas Dickey
Subject: Re: ncurses, libtool, and os x
Date: Thu, 18 Sep 2003 12:00:54 -0400 (EDT)

On Thu, 18 Sep 2003, Chris Zubrzycki wrote:

> > You could try using --with-shlib-version
> Well, actuaclly on os x it's named libncurses.5.0.3.dylib, but the
> version and compat versions are 6.x only if built with libtool. The

so libtool makes it

> problem is that libs with a version of 0 are generally a BadThing on OS
> X, and they made a general solution of adding 1 to both the version and
> compatibility version. I don't think many people other than myself (and
> the fink project) use libtool to build it, since it isn't the default
> to do so. I see a problem though, where people may build it with
> libtool/using fink, and then get pre-made binaries that are linked
> against ncurses built without libtool, and because it's a lower ABI in
> the app than the lib, it will refuse to work. I tried
> - --with-abi-version=4 in the configure line, to have libtool add 1 and
> make it 5, but that didn't work, the libs still had an ABI of 6.0.0.

so I see - the rules I've got for darwin use $(NCURSES_MAJOR) and
$(NCURSES_MINOR) rather than $(ABI_VERSION).  I think I have enough
information to be able to make libtool do the expected thing on my next
patch -- I'll add that to my to-do list.

Note that in general it's not possible to make the versions match up,
since libtool uses its own convention for version numbers.

Thomas E. Dickey

reply via email to

[Prev in Thread] Current Thread [Next in Thread]