[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

dlsym not needed when linking statically

From: felix-ncurses
Subject: dlsym not needed when linking statically
Date: Fri, 14 Oct 2005 14:37:35 +0200
User-agent: Mutt/1.5.11

I just tried to link ncurses 5.5 statically with the diet libc, and it
fails.  It fails because configure wants to have dlsym (which is not
there when linking statically).  Why does it want to have dlsym?  So it
can check whether libgpm.so (which does not exist when linking
statically) has a dependency on libcurses.so (as far as I can see).

Please remove this evil kludge from configure, at least in the case
--enable-static --disable-shared.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]