[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ncurses 5.4 build problem

From: Christopher Parker
Subject: Re: ncurses 5.4 build problem
Date: Thu, 21 Sep 2006 22:05:20 -0500


Thanks for your help. I did find the culprit and the bouncing ball has passed to GAWK. I don't think it will stop there though. The problem is that the command:
echo "parm1 parm2" | awk '{print $1}'
returns "parm1 parm2" instead of just "parm1" This is causing a problem with the test later on in the ncurses configure script.

----- Original Message ----- From: "Thomas Dickey" <address@hidden>
To: "Christopher Parker" <address@hidden>
Cc: <address@hidden>
Sent: Saturday, September 16, 2006 9:25 AM
Subject: Re: ncurses 5.4 build problem

On Fri, 15 Sep 2006, Christopher Parker wrote:

----- Original Message ----- From: "Bob Rossi" <address@hidden>
To: "Christopher Parker" <address@hidden>
Cc: <address@hidden>
Sent: Wednesday, September 13, 2006 6:15 AM
Subject: Re: ncurses 5.4 build problem

On Tue, Sep 12, 2006 at 07:04:59PM -0500, Christopher Parker wrote:
I am trying to build ncurses 5.4 on a CentOS system. During the config and
make process I am running into errors.  I am not sure what other
information you need.  The host system is an s390 system.

The error messages I see are the following:
During config:
13:31:26 checking if /tools/bin/g++ supports vscan function...
13:31:36 stdio
13:31:37 checking for library subsets... termlib+ext_tinfo+base+ext_funcs
13:31:37 checking default library suffix...
13:31:37 checking default library-dependency suffix...
13:31:37 ./configure: line 11784: test: too many arguments

What does the configure file look like at line 11784? Showing a few
lines before and after would be helpful.

Bob Rossi


I'm not sure what all you wanted. I upgraded to 5.5 based on Thomas' suggestion. I still get the same error, but it is now at line 13651. I have

line 13651 is

 if test $DFT_LWR_MODEL = shared ; then

and DFT_LWR_MODEL is set on line 4144:

 DFT_LWR_MODEL=`echo "$cf_list_models" | $AWK '{print $1}'`

Either there's something wrong with $cf_list_models, or the script could
not find a usable awk ($AWK symbol).  The output of the configure script
for the latter should have looked something like

checking for specified models...  normal debug
checking for default model... normal

Thomas E. Dickey

reply via email to

[Prev in Thread] Current Thread [Next in Thread]