[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: A_BLINK has no effect in Xfce-terminal

From: Thomas Dickey
Subject: Re: A_BLINK has no effect in Xfce-terminal
Date: Sun, 1 Feb 2009 06:54:49 -0500 (EST)

On Sat, 31 Jan 2009, Virchanza wrote:

I was debugging a program of mine that uses A_BLINK. The problem I was
having was that A_BLINK was simply having no effect, i.e. it wasn't making
text blink on the screen. I was running my program in Xfce-terminal (this is
the terminal emulator that comes with the Xfce desktop environment for

Anyway, on a hunch, I opened up a fresh terminal outside of X Windows, and
ran my program again. Lo and behold, the text flashed as intended.

Is anyone aware of any issues with A_BLINK when it comes to X Windows
terminal emulators on Linux?

Some emulators implement blink, some implement it "some" of the time
(I noticed one a while back that doesn't combine blink with color...).

Looking at xfce-terminal 0.2.8, I see it doesn't implement blink
(using vttest, menu 2 - vttest shows other problems).

On Debian/testing - I see it also sets $TERM to "xterm" which is incorrect. I hadn't paid much attention to xfce-terminal specifically since it's just a lightweight (though ldd lists 56 libraries) wrapper for the VTE widget, which is used in gnome-terminal.

A terminal description that matches the terminal properly won't list capabilities that the terminal doesn't support.

Thomas E. Dickey

reply via email to

[Prev in Thread] Current Thread [Next in Thread]