[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Build failure with GCC 5.2.1

From: Sven Joachim
Subject: Re: Build failure with GCC 5.2.1
Date: Mon, 10 Aug 2015 06:29:10 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.5.50 (gnu/linux)

On 2015-08-10 03:18 +0200, Thomas Dickey wrote:

> On Sun, Aug 09, 2015 at 06:59:23PM +0200, Sven Joachim wrote:
>> On 2015-07-26 03:04 +0200, Thomas Dickey wrote:
>> >    + use alternate workaround for gcc 5.x feature (adapted from patch by
>> >      Mikhail Peselnik).
>> I'm afraid this alternate workaround does not work at all, since I'm now
>> getting precisely the same failure as in https://bugs.debian.org/777461:
> I might have fixed this last week: I tried a couple of builds (including
> what I had as your set of options), and both worked.

Sorry for not mentioning it, but I actually tested only the final 6.0
release.  And a closer look shows that the 20150715 patchlevel actually
builds with GCC 5.

> Last week, I was fixing test-builds on Unix platforms, and while making
> workarounds, improved one of the regular expressions.
> The chunk in MKlib_gen.sh (which narrows down the compiler/version)
> now looks like this:
> PRG=`echo "$1" | $AWK '{ sub(/^[[:space:]]*/,""); sub(/[[:space:]].*$/, ""); 
> print; }' || exit 0`

This is the problem, I now get

PRG=gcc -E -g -O2 -fstack-protector-strong -Wformat -Werror=format-security 
--param max-inline-insns-single=1200

i.e. the whole bag of "$(CPP) $(CPPFLAGS)" from ncurses/Makefile, rather
than just PRG=gcc as it's supposed to be.  This might be a bug in
Debian's version of mawk, since it works with gawk.

> FSF=`"$PRG" --version 2>/dev/null || exit 0 | fgrep "Free Software 
> Foundation" | head -n 1`
> ALL=`"$PRG" -dumpversion 2>/dev/null || exit 0`
> ONE=`echo "$ALL" | sed -e 's/\..*$//'`

Since "$PRG" is not found, there is a problem.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]