[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNU Parallel Bug Reports Latest parallel in non-default prefix gives

From: Ole Tange
Subject: Re: GNU Parallel Bug Reports Latest parallel in non-default prefix gives errors about retired options
Date: Thu, 28 Aug 2014 21:11:25 +0200

On Thu, Aug 28, 2014 at 12:49 PM, Robin Neatherway
<address@hidden> wrote:
> Hi,
> I installed parallel-20140822 using:
> However, when I try a simple test I get errors about retired options:
> $ ls | parallel echo {}
> parallel: Error: --tollef has been retired. Use -u -q --arg-sep -- and
> --load for -l.
> I am using Fedora 20. $PARALLEL is not set. I checked for config files
> and unhelpfully:
> $ cat /etc/parallel/config
> --tollef
> I'm not sure why I received all the other errors though as well. I
> then tried running with --gnu to override this bad option, but this
> gave the same output.

--tollef was retired after being obsolete for a full year:

> Either using --plain or creating an empty profile and using that every
> time on the command line worked:
> $ echo > ~/.parallel/config
> $ ls | parallel --profile=config echo {}
> file1
> file2
> ...

Don't do that. Remove the retired --tollef option instead. If the
--tollef in /etc/parallel/config is installed by a package, please
escalate this to the package maintainer.

> I may be mistaken, but there seem to be a few bugs here:
> 1. --gnu doesn't override --tollef although it states that it does in
> the manpage

This is what it says in the man page:

      --gnu    Behave like GNU parallel. If --tollef and --gnu are both set,
                  --gnu takes precedence.
                  --tollef is retired, but --gnu is kept for compatibility.

There is no section in the man-page for --tollef, thus is it not a
supported option and if you use --tollef GNU Parallel will not run no
matter which options you combine it with.

If you do not feel that is described clearly in the manual, please
help by rephrasing the manual.

> 2. /etc/parallel/config is only mentioned in the manpage as somewhere
> that you *cannot* put --filter-hosts
> 3. ~/.parallel/config does not seem to take precedence over 
> /etc/parallel/config

You cannot put options that are retired in any config file.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]