[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Galaxy FreeBayes Bug Follow-up

From: Ole Tange
Subject: Re: Galaxy FreeBayes Bug Follow-up
Date: Fri, 26 Mar 2021 09:24:11 +0100

On Wed, Mar 24, 2021 at 8:13 PM Julianne Marguerite Radford
<jradfor8@uwo.ca> wrote:
> Julianne Marguerite Radford has shared a OneDrive for Business file with you. 
> To view it, click the link below.
> 28_ MarkDuplicates on collection 137_ MarkDuplicates BAM output.zip

I tried thrice: Download fails after ~150 MB.

> Hi there,
> I am resubmitting my error report in attempt to include everything from the 
> GNU parallel link.
> Parallel version:
> The version number: 20170422
> Example of what happened:
> I used a paired sequence collection of BAM files from the MarkDuplicates tool 
> output as input into the FreeBayes tool (BAM files attached as 
> "28_MarkDuplicates..." file). These BAM files were created using BWA mapping 
> in Galaxy. Everything should have worked fine because I have already run this 
> tool before with these reads. The only difference is, last time I ran it, I 
> used "output single VCFs"... but this time, I was running it to get a merged 
> VCF output. So, for the parameters I selected the "merge output into one VCF".

Does it do this every time on every input or only now and then?

You need to assume that the ones who are going to fix this have never
heard of Galaxy, FreeBayes, VCF and BWA, and have no idea how to use
those. Assume they are experts in GNU Parallel, but know nothing else.
So if this problem only occurs with this combination of the tools, you
need to instruct them how to install these tools and how to run them.
Because of the huge complexity of this, it is often easier just to
make a virtual machine with all the data and programs, and give a
download link to that. You will still need to show exactly how to run
the programs on the input.

If you can trigger the problem without using special tools, it will
make it much easier. Especially if you include a code sample that does
not work. See:

> parallel: This should not happen. You have found a bug.
> Please contact <parallel@gnu.org> and include:
> * The version number: 20170422

Quite a bit has happened since 2017, so the first thing I would do
would be to upgrade to 20210322 and retry.

> * The bugid: fdr: Cannot open 
> /jetstream/scratch0/main/jobs/34156384/_job_tmp/parRdbkY.par

Here it will be good to know if other programs access
/jetstream/scratch0/main/jobs/34156384/_job_tmp (maybe there is a
cleanup program that automatically removes files) and what kind of
file system this is (maybe it is a special kind of file system that
has a race condition). Both of these would be easier for me to check
if I had a virtual machine that is an exact copy of your setup.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]