[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Big Problem with Winodows Me

From: J. Henning Schwentner
Subject: Big Problem with Winodows Me
Date: Wed, 21 Feb 2001 10:08:55 +0100

Hi Andrew,

I just found out, that parted cannot deal with great partitions created with
Windows ME fdisk:

I created a primary Fat32 partition (Size: 10G, type=c (fat32 lba)) with ME
fdisk. Then I started parted and tried "p", but the answer was "cannot open
device /dev/hde - unrecognised disk label".

I removed the partition and created a new one, but this time only with 1G
(type=b (Fat32 non-lba). Now parted worked perfectly.

After recreating the first situation I took a closer look to the partition
table ME fdisk created: linux fdisk showed me that the (placeholder chs)
last cylinder was 0xfa (dec=250), but I think 1023 would be right? The other
placeholders are like the geometry: H: 254 S: 63.

The geometry of the disk is (according to parted and linux fdisk)

I tried the same on another system with /dev/hda as first HDD but it showed
the same.

So, I think the problem is that parted only accepts the placeholder value
"1023" for ECyl, is that possible?

Henning Schwentner

reply via email to

[Prev in Thread] Current Thread [Next in Thread]