[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Big Problem with Winodows Me

From: Andrew Clausen
Subject: Re: Big Problem with Winodows Me
Date: Wed, 21 Feb 2001 09:27:19 -0300

"J. Henning Schwentner" wrote:
> Hi Andrew,
> I just found out, that parted cannot deal with great partitions created with
> Windows ME fdisk:
> I created a primary Fat32 partition (Size: 10G, type=c (fat32 lba)) with ME
> fdisk. Then I started parted and tried "p", but the answer was "cannot open
> device /dev/hde - unrecognised disk label".

Tom Roelz found a problem like this too, but we never figured out
Windows ws creating such partition tables.
> I removed the partition and created a new one, but this time only with 1G
> (type=b (Fat32 non-lba). Now parted worked perfectly.

> After recreating the first situation I took a closer look to the partition
> table ME fdisk created: linux fdisk showed me that the (placeholder chs)
> last cylinder was 0xfa (dec=250), but I think 1023 would be right? The other
> placeholders are like the geometry: H: 254 S: 63.

Could you try creating partitions of different sizes?  Perhaps 0xfa
should have the same meaning as 1023 (too big for CHS).
> So, I think the problem is that parted only accepts the placeholder value
> "1023" for ECyl, is that possible?


Andrew Clausen

reply via email to

[Prev in Thread] Current Thread [Next in Thread]