[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: unable to align partition

From: Ibraheem Umaru-Mohammed
Subject: Re: unable to align partition
Date: Thu, 17 May 2001 00:36:48 +0100

16/05/01 23:58:21, Andrew Clausen <address@hidden> wrote:
>When you resize a partition with Parted, the file system gets
>resized as well.  So the file system and partition size will
>always match.

Okay. Seems reasonable.

>If you put the start at 000.0000 (exactly at the start of the disk),
>Parted's constraint solver will find the closest valid match
>(probably 0.031).

Sounds logical.

>If you resize the partition to ANY size (even the same size),
>the constraint solver will try to align it properly.  (so,
>a request for the same size will actually give you a slightly
>different, aligned size)


However, this doesn't seem to be working for me. I have just tried to redo 
everything again, and made notes 
that I have reproduced below:

i) Firstly I checked my BIOS settings on startup I found the following:

        cylinders       heads   sectors size
        39715   16      63      20498MB

ii) Then I tried to run parted and got the following on when run with /dev/hda 
as the command line argument:

        Warning: The operating system thinks that the geometry on /dev/hda is 
        Therefore, cylinder 1024 ends at 8032.499M. You should check that this 
matches your 
        BIOS geometry before using this program.

iii) I then ignored the message, and proceeded to run the print command:

        Disk geometry for /dev/hda: 0.000-19547.214 Megabytes
        Disk label type: msdos

        Minor   Start   End     Type    Filesystem      Flags
        1       23.563  6024.375        primary FAT             boot,lba

iv) I then tried to run the resize command as you said. I ran the following 

        resize 1 0.000 6024.375

And got the following warning:

        Warning: Partition size (12289662 sectors) and filesystem size 
(19968732 sectors) do not match.

v) I ignored this message again, and then got the following:

        Error: Attempt to read sectors 12510996-12511011 outside of partition 
on /dev/hda 

vi) I tried to keep ignoring these messages but just kept getting messages 
similar to the one above. The message following
the one above was:

        Error: Attempt to read sectors 12552868-12552883 outside of partition 
on /dev/hda

Then I gave up, and rebooted into Windows to send this message.

Does this information help at all? 
Do you have any idea what is amiss?

Kindest regards,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]