[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: up to 12 seconds to print partition table!

From: Timshel Knoll
Subject: Re: up to 12 seconds to print partition table!
Date: Tue, 26 Mar 2002 17:01:15 +1100
User-agent: Mutt/1.3.27i

On Mon, Mar 25, 2002 at 05:32:34PM -0700, Andreas Dilger wrote:
> On Mar 25, 2002  23:55 +0000, Richard Hirst wrote:
> > On Mon, Mar 25, 2002 at 04:49:31PM -0700, Andreas Dilger wrote:
> > > This problem is fixed in parted 1.6.  I noticed it as well, and it was
> > > annoying.
> > 
> > OK, thanks.  Must get round to trying 1.6, but my initial attempts to
> > build it on ia64 failed.  Havn't really investigated yet.  See, for
> > example:
> > 
> > http://buildd.debian.org/fetch.php?&pkg=parted1.6&ver=1.5%2B1.6.0-pre3-1&arch=ia64&stamp=1015685510&file=log&as=raw
> Yes, I had a similar problem when I tried to use the libblkid headers
> with libparted.  Both tried to define int8_t and such.  I solved it by
> changing the order of the headers, but that is not really the correct
> solution.  I'm not sure who is at fault here - libparted or libc
> headers.
> Cheers, Andreas

That problem's a recurrence of a common build failure. <asm/page.h> used
to be #include'd by heaps of files, and builds failed all over the place
because of it. It's actually nothing to do with parted really, because
sys/types.h is a glibc header and asm/types.h is a Linux header, so the
problem is really with one (or both) of these two.

A quick check suggests that a simple switch of the order of the headers
won't actually fix this, since neither of these headers check for
previous definitions (they both use typedef rather than #define anyway,
so these checks aren't trivial), except sys/types.h which checks
"#ifdef __int8_t_defined" before typedef'ing the appropriate stuff. So
maybe "#include <asm/types.h>" first, then doing
"#define __int8_t_defined", "#include <sys/types.h>" might be a _very_
ugly hack around this problem.

Actually, looking at /usr/include/asm/page.h on caballero.debian.org, I
can't see any typedef's or #define's of *int*_t types, which is wierd.
Maybe this issue has been fixed?

I'll upload a pre-release package of -pre5 to experimental and see how
that goes with the buildd's.



   Timshel Knoll <address@hidden>, Debian email: <address@hidden>
          Debian GNU/Linux developer: http://people.debian.org/~timshel/
                             GnuPG public key: finger address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]