[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

address@hidden: Bug#145214: libparted1.4: Fatal error when printing part

From: Timshel Knoll
Subject: address@hidden: Bug#145214: libparted1.4: Fatal error when printing partition table on iBook 2001 Dual USB]
Date: Sat, 18 May 2002 01:52:21 +1000
User-agent: Mutt/1.3.28i

[please preserve the CC to @bugs.d.o ... - cheers]

Hi Andrew,

I recieved this a couple of weeks ago ... I've been pretty busy with uni
for the last few week so haven't had the chance to look at it. No ide
on whether this affects the 1.6.x series either ...



----- Forwarded message from Jimmy Kaplowitz <address@hidden> -----

Subject: Bug#145214: libparted1.4: Fatal error when printing partition table on 
iBook 2001 Dual USB
From: Jimmy Kaplowitz <address@hidden>
To: Debian Bug Tracking System <address@hidden>
X-Mailer: reportbug 1.50
Date: Tue, 30 Apr 2002 00:46:43 -0400
X-Spam-Status: No, hits=-4.5 required=5.0 tests=FORGED_RCVD_FOUND,SENT_BY_BTS 

Package: libparted1.4
Version: 1.4.24-4
Severity: important

I have an iBook 2001 Dual USB (i.e., an iBook2 600 MHz 12" screen
w/combo drive). When running parted on my hard drive (which has the
usual macos driver partitions, a macos9 partition, a macosx partition,
and a debian partition with sid installed), I get the following error:

address@hidden:~# parted /dev/hda print
Error: The boot region doesn't start at the start of the partition

That is all the output I see when running it under X. When I run it on
the console I also see lots and lots of repetitions of "invalidate: busy
buffer". I have had this explained to me as a nonfatal warning caused by
a kernel bug in which the partition cache is not properly invalidated,
and I've been told it doesn't interfere with anything. Also, supposedly
the parted developers already know about it. However, the boot region
error above does interfere with my ability to use parted.

I am filling this bug against libparted1.4 rather than parted because
the same error message is returned when calling libparted through the
python bindings in the python-parted package. This is the only method of
partitioning used by the PGI graphical installer for Debian (package
pgi), and I am working on getting it functioning on PowerPC. At least
for NewWorld PowerMacs, partitioning is the only major remaining
hurdle. It would be great to have a very easy-to-use installer for
Debian on Macs as well as PCs (it also works on Itanium, btw), and with
this solved it should be a reality very, very soon.

Thanks for looking at this bug report, and I'll be glad to pass on any
additional info that is needed, do tests, etc.

Please keep Branden on the CC list, since he is the primary author of
PGI and is therefore very interested in the resolution of this bug.

- Jimmy Kaplowitz

-- System Information
Debian Release: 3.0
Architecture: powerpc
Kernel: Linux fugue.bway.net 2.4.19-pre7-ben0 #1 Sun Apr 28 01:42:35 EDT 2002 

Versions of packages libparted1.4 depends on:
ii  e2fsprogs                     1.27-2     The EXT2 file system utilities and
ii  e2fsprogs [libuuid1]          1.27-2     The EXT2 file system utilities and
ii  libc6                         2.2.5-4    GNU C Library: Shared libraries an
pn  libuuid1                                 Not found.

----- End forwarded message -----

Timshel Knoll <address@hidden>, Debian email: <address@hidden>
Debian GNU/Linux developer: http://people.debian.org/~timshel/
GnuPG public key: finger address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]