[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: apologies for my ignorance

From: David Leuser II
Subject: Re: apologies for my ignorance
Date: Wed, 02 Oct 2002 10:02:43 -0400

Thanks! I read right over the doc line to use a boot disk (in section
2.5.1) and totally spaced it.  I had originally tried changing run-levels
thinking that would make sense... left-overs from an overtired person who
grew up on windows 3.1 i guess.

Could someone please tell me what my #4 "lba" partition is that seems to
overlap with everything after it on the disk?  (see below) I'm afraid to
start moving data around... if i understand the process correctly i have
to first shrink /usr (#5) and move the free space physically after /usr to
be physically after /home (#2) before i can increase the size of /home...
Given this process is correct, what do I do with that lba partition (if
anything)?  --thanks

Disk geometry for /dev/sda: 0.000-17355.750 megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.031     54.909  primary   fat16
2         54.910   1082.504  primary   ext3
3       1082.505   1106.037  primary   ext3        boot
4       1106.038  17351.455  extended              lba
5       1106.068  10260.263  logical   ext3
6      10260.294  15743.386  logical   ext3
7      15743.417  16770.981  logical   linux-swap
8      16771.012  17280.856  logical   ext3
9      17280.888  17343.610  logical   ext3

address@hidden writes:
>On Mon, Sep 30, 2002 at 06:58:41PM -0400, David Leuser II wrote:
>> I would REALLY REALLY appreciate it if any wise linux gurus could take
>> under your wing...
>I'm sorry, I'm no guru.  Trust anything I write here appropriately ;-)
>> I want to grow /home (Minor #2) by 4.5 gb.  I was thinking I would
>> /usr (minor #5) to be smaller (change the end from 10260 to 5760) to get
>> the space to do this.  That's when i rebooted and got nasty errors i
>> didn't understand, resized it back, and breathed a sigh of relief at my
>> good luck that fixed it... But now I don't know what to do? Whilst
>> to resize, partent was spitting scary warnings at me like 'failed to
>> cleanly unmount' or something to that effect.
>It sounds like you were trying to use Parted to resize a partition
>a file system that was still mounted.  In other words, you tried to
>resize a
>partition that Linux (the kernel) was allowed to write to.  As you'd
>that's not a good idea.
>So you must first unmount the file system on that device using a command
>       # umount /usr
>But since /usr is such an important and frequently used part of the
>system, I
>think you'll actually be better off running Parted from a boot disk (in
>you might not really have a choice).  That way you can run Parted on the
>with none of the file systems on your server's disks being mounted at the
>See the Parted manual http://www.gnu.org/manual/parted-1.6.1/ for more
>information.  Actually, from memory, I think the section on creating a
>boot disk
>is out of date and that you need to create two disks, a root disk and a
>disk.  There is more information to be found at the FTP site mentioned in

David M. Leuser, II
Assistant Network Administrator
New Hampton School
(603) 744-3182 x121
"Picture the root account as a magic hat that gives you lots of power,
with which you can, by waving your hands, create or destroy entire cities.
Because it is easy to wave your hands in a destructive manner, it is not a
good idea to wear the magic hat when it is not needed, despite the
wonderful feeling. " -- Gnome User's Guide

reply via email to

[Prev in Thread] Current Thread [Next in Thread]