bug-parted
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Bug in parted - fs too big


From: Philippe Froidevaux
Subject: Bug in parted - fs too big
Date: Wed, 20 Nov 2002 09:17:51 +0100
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Hi,

I have a problem with GNU Parted 1.6.3, on linux RedHat 7.3. I tried to expand an LVM (and then, in a second try, a simple SCSI) partition from 1.2Tb to 1.6Tb.

But I got :

1/ a warning : parted said it is neither a SCSI disk, nor an IDE. I can "Ignore or Cancel", and choose to Ignore, so it's not a real problem. It work fine on little partitions (I tried with partition size < 100 Gb, with both LVM and SCSI). But it gives me the message with both LVM and standard SCSI disks. SCSI should be detected...

2/ an error : on the LVM part, the command "parted /dev/vg00/lv01 check" gave me a *negative* value for the partition size ! Then the program freeze while growing the partition - I leave it running more than 6 hours. I didn't try whith the SCSI disks (I can't currently umount this partition, sorry).


So my questions :
- can I pass this size limitations, and how ?
- maybe it were a good idea to document this limits in the man page :)
- how can I give you more information for debugging ?

And a request :
- it should be usefull to add a "progress bar" when parted is growing a partition. I didn't know if 'parted' was frozen or working :)

thanks,


regards,
Philippe.

PS: if this adress is a mailing-list, I'm not subscribed - so please send me a copy of your answer.


--

Meilleures salutations / Mit freundlichen Gruessen / Kind regards

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Philippe Froidevaux                  address@hidden
D├ępartement d'Informatique                        Systems Manager
Rue de Faucigny 2                        tel: +41 (0)26 300 83 42
CH-1700 Fribourg                         fax: +41 (0)26 300 96 42






reply via email to

[Prev in Thread] Current Thread [Next in Thread]