[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem in detecting RAID device!!

From: Veerapuram Varadhan
Subject: Re: Problem in detecting RAID device!!
Date: Wed, 25 Dec 2002 17:14:59 +0530 (IST)

> On Tue, Dec 24, 2002 at 12:10:05PM +0530, Veerapuram Varadhan wrote:
>> > Why not use 1.6.x?
>> I havent tried 1.6.x yet, though, will it be compatible with 1.4.x? I
>> mean, if i compile my code which currently uses 1.4.x in 1.6.x, will
>> it get compiled or do i need to do any modifications? (since in the
>> /doc/API, i find some older version functions missing.)
> They are not compatible, but it isn't a lot of work to port from
> 1.4.x to 1.6.x.
> For example, if you don't want to use PedTimer's, just pass NULL...

Thank you once again, i will port my program to use 1.6.x of parted.
BTW, my problem still exists even if I use parted 1.6.2.  The following is
the total scenario of my problem.

I have a SCSI based RAID device with Mylex RAID card and i am using RAID
level 5.  I tried to partition using the tool which i have written using
libparted 1.4.x (now i will be porting it to 1.6.x as suggested by Andrew)
which said "No device found".

So, i tried with Redhat 7.3 installation.  The Diskdruid was able to show
the device (/dev/rd/c0d0) properly.  Though, when i tried the same using
parted in their (Redhat 7.3 installation) "shell" mode, i got "No device
found".  Can anyone guide me what could be the possible cause of this

However, if I use 2.4.17 kernel my program is able to get devices list
(ped_device_get_next() is able to return a valid device).  Now i am using
2.4.18-3 (the same kernal that RH 7.3 installation is using).


V. Varadhan.

> Cheers,
> Andrew

reply via email to

[Prev in Thread] Current Thread [Next in Thread]