[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Error: fat_table_alloc_cluster: no free clusters (all fs intact afte

From: Fernando Fuganti
Subject: Re: Error: fat_table_alloc_cluster: no free clusters (all fs intact after pt recovery!)
Date: Thu, 7 Aug 2003 11:22:24 -0300
User-agent: Mutt/1.3.28i

On 11/07/2003 at 12:19:29, Andrew Clausen wrote:
> > this happening to me near at the end (I think) of resize operation to shrink
> > partition to smallest size possible - passing to parted a value lower than
> > the real start and smaller than real size - and after that, the partition
> > table became corrupted...
> That is very strange.  Even if the resize fails, it shouldn't corrupt
> the file system or the partition table.

as partition table was corrupted, 2 partitions entries were lost: one ext2
(the one before fat) and other FAT32 (parted was working on that when error

my very first attempt to recover was failed (gpart and parted found nothing,
even changing sector size and scan increment). After that, I leave computer
alone and got back to work on it tomorrow. After trying with modified
rescuept and findsuper (from ext2fsprogs) I recovered with no trouble, just
adjusting start of partition to new position. With FAT32 was the same: I
just get the right partition position by using testdisk (from Christophe
GRENIER, GPLed), that found ALL my partitions with no trouble and precision.
> So, it looks like I miscalculated the minimum size the FAT resizer needs,
> which would explain the first (but not subsequent problems).
> I had a look, and there's a bug in checking the return codes, so Parted
> might have believed the resize succeeded, which is bad.  I'd expect
> your file system to be toast, but not your partition table to be also.

fixed in 1.6.6 ?
> Perhaps there was memory corruption from the bug (I wouldn't be
> surprised), which would explain it.

I don't know (by now). My machine is 4 years old and working pretty well
since new and passed three 72hours memtest rounds with no errors. perhaps
something with bus/ide/disk high usage... I will investigate, thanks !
> BTW, Parted can do gpart-type stuff...

humm... not worked for me :(

for ext2, only findsuper and testdisk worked with no modifications.
for FAT32, testdisk worked great (with a 10 seconds try ;)

obrigado novamente e espero que eu tenha ajudado em algo !

Fernando Fuganti
Aeroclube de Planadores de Balsa Nova
Visite: www.planador.org.br - www.planadores.org.br

reply via email to

[Prev in Thread] Current Thread [Next in Thread]