[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

parted resize experience suggests some improvements

From: Sven . Hartrumpf
Subject: parted resize experience suggests some improvements
Date: Fri, 05 Sep 2003 09:57:37 +0200 (CEST)

Hi all.

I was running parted 1.6.5 for Linux, wanted to shrink my
/home partition to get some space for a new swap partition,
and had a day of hell which ended well.

Don't get me wrong: I made a mistake (see 4. below), so I am to
blame, not parted. But maybe parted can be improved so that
some of the trouble can be avoided in the future.

Here is what I did:

1. "resize" my /home partition. Worked o.k. (I think).

2. (in the same parted session): "mkpartfs primary swap ..."
   for the now free area at the end of the disk

3. "parted" asked for new parameters (because(?) the new partition
   would habe been the fifth primary (or extended) partition).

   Suggestion: report an error and do not ask for new values.

4. I changed "primary" in 2. to "logical" - what a stupid
   mistake of mine - don't do that! - because the range was
   - of course - outside my extended partition, at the end of the
   disk in free space.

   Result: the parted process ran forever, I had to kill it after
   3 hours of CPU time (checked with "top").

   Suggestion: parted should check ranges of logical partitions.

5. I ran /sbin/lilo and rebooted my machine which reported:

"The filesystem size (according to the superblock) is 6875820 blocks
The physical size of the device is 6323585 blocks
Either the superblock or the partition table is likely to be corrupt"

   So, the filesystem had not been adjusted by parted. I wonder
   why parted hasn't done this in step 1.

6. fsck was reporting the same problem. When I insisted to continue
   it apparently fixed (after querying some thousand questions)
   the strange blocks from the swap filesystem which resulted
   from 4.

7. To be sure, I made again two verified backups of my /home
   partition which I could mount read-only (ro).

8. I fixed the error by using parted's resize again to restore
   the old end value of the /home partition. (Once more: it's good
   to have a print out of the correct partition table.)
   Parted reported the problem from 5., but by typing "I" for ignore
   I was able to get it done.

   Suggestion: The prompt "Ignore/Cancel" is too cryptic for me.
   "To ignore this warning, type I or i." (I am not sure about i.)
   "To cancel yout command, type C or c." (I am not sure about c.)
   (Maybe documentation for this prompt should also be added;
    and what happens if I enter something else?)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]