[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Big Trouble - MBR and partition table modified but not completed

From: Zlatko Savic
Subject: Big Trouble - MBR and partition table modified but not completed
Date: Sun, 07 Dec 2003 01:19:16 -0500
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031013 Thunderbird/0.3

I am an intermediate level Linux user and I have used Parted before without trouble. The current issue did not arise from problems using Parted. I am hoping that this list may help me to use Parted to fix problems that occurred before.

First let me show you my harddrive(s) partition layout:
hdc => [Windows ME]
hdd => [Mandrake 7.2: "/"][swap][Mandrake7.2:"/home"][Mandrake 9.2 "/"][swap][Mandrake 9.2 "/home"][WinXP][some data: FAT32]

I used Diskdrake in Mandrake 9.2 to remove two old Mandrake 7.2 partitions from my harddrive (and the swap in the middle of it). I wanted to use the extra 2Gig for storage. I "deleted" the partitions and pressed the 'done' button. Diskdrake gave messages such as "partition table modified" or "partitions are written to disk" (something similar). It also stated that the partitions would be renumbered. At the same time I was running the Totem Media player which crashed quite often during playing but I could always 'xkill' it. However, this time the system froze, not even the mouse pointer would move. I had to restart the system cold turkey. I don't know whether the partition change caused the freeze or the media player.

My MBR usually loads first LILO with Mandrake 9.2 as default, and has also the option for Windows which brings me to a second menu that lets me choose between ME and XP. After the partition change I could not load MDK 9.2 (kernel panic) and I could not load WinXP (hardware issue stated on screen). Win ME loaded fine and so I loaded it. The Windows explorer did not show the Windows partitions on hdd. However, after loading Win ME theNorton Antivirus 2003 notified me that my boot sector was modified (possible virus threat) and offered me to restore it to the original setting. I thought this would solve the issue but now every time I reboot, the MBR just says "stage1 stage2" and breaks up and reboots the machine again. I cannot boot anything at all.

I even tried to install Red Hat 9 into the place of the two "cursed" partitions (hoping that RH would attempt to fix the partition table) but RH9 only allowed me to ignore it or to cancel it. And according to the RH9 install GUI program, I had two partitions that were free (on hdd), the first in the size of partitions I wanted to get rid of (approx 2Gig) and the second representing all the other partitions as one.I did not proceed with the installation since it did not promise any good results.

My main goal is to save some data that I have on the last partition on hdd. I can reinstall everything if it has to be. I suspect that the MBR, the partition table and the partition start and end sectors are out of sync.

I ran RH9 install CD in rescue mode - testing to see what Parted would report. This is the output:
unable to align partition properly. this probably means that another partitioning tool generated an incorrect partition table, because it didn't have the correct BIOS geometry. It is safe to ignore, but ignoring may cause (fixable) problems with some boot loaders.

error: invalid partition table on /dev/hdd - wrong signature 0
minor    start        end        type        filesystem    flags
1    2099.210    14305.429    extended            boot

Any help is truly appreciated and will save me from performing "crash-test-dummy" tests with my harddrive...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]